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Info de base

Principes des données

Tableaux

• Créer un tableau

• Mise en forme

• Trier et filtrer les données

PivotTables

• Créer des PivotTables

• Grouper

• Calculer

• Filtrer



Tableaux -base



Tableaux Excel

• Un tableau Excel transforme la liste de données d’une
zone de cellules, en un objet de lignes et colonnes

• Avantages principaux
• Mise en forme facile

• Procéder des fonctions

• Élargissement automatique

• Les formules réfèrent aux colonnes
=SUM(B2:B654) vs =SUM(vendre2015[Aout])

• Source pour PivotTables
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Créer des Tableaux Excel

1. Cliquez dans les données

2. Choisissez HOME/ Styles/ Format as Tables

3. Faites un clic droit et choisissez Apply and clear
formatting

4. Modifiez le nom du tableau
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Format as Table

Table Name

Format



Créer des Tableaux

Ouvrez : 1_A_1_Create Tables.xlsx

1. Sur Sheet 1: Convertissez le range en une table, 
supprimez la mise en forme originale

2. Modifiez le nom en Tbl_Orders2018

3. Sur Sheet 2: Créez une nouvelle colonne “Sales Amount” 
entre BtwTvaVat et OrderDate

4. Tapez le formule multipliant Quantity, PricePerUnit et 
BtwTvaVAT+1

5. Appliquez la mise en forme Comma Style



Trier et Filtrer rapidement – colonne seule



Triage Multi-level/avancé



Filtre avancé

• Comparez 2 tableux

• Choisissez Data / Filter / 
Advanced

• Les Sélections doivent
toujours avoir des Headers



Trier et Filtrer

1_B_2_Sort.xlsx

1. Triage normal

2. Triage avec liste ajustée

3. Triage par couleur

1_B_3_Filter.xlsx

1. Filtre Texte normal

2. Filtre Date normal

3. Filtre numérique normal

4. Filtre avancé

5. Filtre “between” avancé



PivotTable -base



PivotTables

• Analyse de grands nombres de données

• Fonctionnalité par défaut de Excel

• Forme ‘légère’ de BI

• Un PivotTable vous fait exécuter 3 tâches
• Grouper

• Synthétiser (aggréger)

• Filtrer



PivotTables

ID Cust Date Proj City Status Budget

1 2016 Gent Open 15.000

2 2016 Liège Closed 12.200

3 2016 Bxl Closed 8.950

4 2016 Gent Open 4.450

5 2015 Bxl Open 65.850

6 2015 … … …

Closed Open

Bxl 8.950 65.850

Gent 19.450

Liège 12.200

…

Source data PivotTable

Grouper

Grouper

Aggréger

2016

Filtrer



Créer un PivotTable

1. Cliquez dans les données source

2. Choisissez Insert/ Tables/ PivotTables

3. Confirmez les données et l’emplacement

4. Choisissez les champs à ajouter

5. Ajustez
• (Sub)Totaux et mise en forme

• Fonction aggrégée

• Présentation Nombre

• Caractéristiques PivotTable
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Contexte de la Fonction

• L’aggrégation est calculée dans le contexte de 
l’emplacement

• Le contexte d’un PivotTable dépend de
• Row headers

• Column headers

• Filters

• Slicers
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Sum of Sales Amount 

met de filter: Bike

Sum of Sales Amount met de 

filter: Car and Executive

Sum of Sales Amount 

ZONDER Filter



Contexte en action
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+ Row and Column 

context

+ Slicer

context

+Filter 

context



Créer des PivotTables

1_C_4_Create_PivotTables.xlsx

• Choisissez Format as Table

• Créez les 2 PivotTables comme indiqué



Paramètres

PivotTable Options (Value) Field Settings

Autofit columns widths on update

Summarization

Number Format



Données en Groupe

Groupez les lignes et colonnes par

• Colonnes existantes

• Grouper à la main

• Date

• Nombre

ID ProductName Category Subcategory Country OrderDate Price Quantity

1234 E-Speed E-bike Speed Pedelec Belgium 12/03/2018 2.356,56 1

5763 City Mobile Bike City Netherlands 18/01/2019 786,95 1

6369 Den Eddy Bike Race Peru 25/05/2019 1.867,89 1

6370 E-Speed II E-bike Speed Pedelec Brasil 25/05/2019 2.290,56 1



Grouper dans PivotTables

1_C_5_Grouping_PivotTables.xlsx

A. Groupez par Date

B. Groupez par Value



Filtrer un PivotTable

Filtres

• Élément intégral du PivotTable

• Mise en forme par défaut

• Appliqué sur un seul PivotTable

Slicers

• Entre les données et PivotTable

• Plusieurs dessins

• Peut diriger plusieurs PivotTables
à travers de plusieurs sheets



Filtres PivotTable

Ajouter des filtres

Utiliser des filtres



PivotTable Slicers

Filter Connections

Insert Slicer



Summarization

1. Sélectionnez le Value Field et chiosissez Field Settings

2. Allez vers Show Values As

3. Sélectionnez le type d’affichage



Présentation dans Excel



Sparklines

• Sélectionnez la zone où les sparklines sont à placer

• Choisissez Insert / Sparklines / Columns

• Ranges:
• Data Range: Données source

• Location Range: emplacement 
sparkline



Options Sparkline

Type

Couleurs

Axes



Conditional format

• Sélectionnez les cellules

• Choisissez Home / 
Conditional Formatting / …

Manage Rules…



Manage Rules

Edit Rule…

Show Bar Only

PivotTables



Power Query



Power Query

• Power Query introduction

• Connections de données

• Exporter vers Excel / Data Model

• Transformations

• Fusionner des tableaux



Power Query - Introduction



Power Query Data sources

• Power Query connecte >45 type de sources dans Power BI

• Power Query connecte >25 type de sources dans Excel



Power Query

• Utilisez Power Query quand les données ne sont pas trop
bonnes

• Transformez les données
• Format, Remove rows, UnPivot, Date2Month … 

• Aggrégation de données
• Import from folder, replace …

• Charge les données dans votre modèle
de données



Example

1. Ouvrez 2_A_01.xlsx

2. Importez la liste via From Table/Range

3. Sélectionnez les colonnes 1-3

4. Choisissez Transform > Unpivot other columns

5. Renommez les colonnes “Attribute” et “Value”

6. Modifiez le type de données

7. …

8. Fermez Home > Close and Load



Excel – Query interface

Queries & Connections

Refresh All

Clic droit

Get Data



Power Query Interface

Queries

Transform & Add Column

Formula Bar*

Query Steps



Interface

• Formula Bar
• View > Layout >  Formula Bar

• Transform
• Modifiez les colonnes sélectionnées

• Add column
• Créez une nouvelle colonne (à base de la colonne

sélectionnée)

• Les boutons ont des options “supplémentaires”



Unpivot Columns

• Transform / Unpivot Columns

Unpivot Columns / Unpivot other columns



Data connections



Importer des fichiers externes vers Excel

1. Créez un nouveau fichier

2. Choisissez Get Data > From File > From Workbook

3. Sélectionnez 2_B_01_data.xlsx

4. Sélectionnez
• Table tbl_Products
• Sheet Production

5. Tbl_products: Fragmentes la colonne Description

6. Production: complétez les Années

7. Choisissez Home > Close & Load

8. Enregistrez le fichier:  2_B_01.xlsx



Text/CSV-Files

1. Créez un nouveau fichier

2. Choisissez Get Data > From File > From Text/CSV

3. Sélectionnez B_02_data.csv

4. Choisissez Home > Close & Load

5. Enregistrez le fichier: 2_B_02



Text/CSV-Files

1. Créez un nouveau fichier

2. Choisissez Get Data > From File > From Text/CSV

3. Importez 2_B_03_data.txt

4. Promouvez la première ligne
Le Startdate n’est pas reconnu correctement
• Choisissez File > Options & Settings > Query options > Regional settings

English: United States
• Ou utilisez Add Column / Column from Example

5. Cliquez sur Refresh Preview

6. Modifiez le type des données de Startdate

7. Cliquez sur Home > Close & Load

8. Enregistrez le fichier: 2_B_03



Databases

• Plusieurs types de bases de données
sont acceptés
• Via Get Data > From Database

• Cette liste est complété via ODBC 
connections
• Via Data > From Other Sources



Démo MYSQL/SQL 

1. Choisissez Get Data > From Database > From MySQL 
Database

2. Nom Server et Database

3. Username et password

4. Sélectionnez les tableaux

5. …



Access

1. Créez un nouveau fichier

2. Get Data > From Database > From Microsoft Access …

3. Sélectionnez 2_B_04_data.accdb ou
2_B_04_data_alternative.accdb 

4. Recherchez et importez Purchase orders of Orders

5. …

6. Choisissez Home > Close & Load

7. Enregistrez le fichier: 2_B_04

À cause d’un “mismatch” entre la version du fichier Acces et votre version de Excel/Power BI, il se peut que 

l’importation faillisse

https://docs.microsoft.com/en-us/power-bi/desktop-access-database-errors

https://docs.microsoft.com/en-us/power-bi/desktop-access-database-errors


Exercises Recap

1. Créez un nouveau fichier

2. Importer des donnees de “Factsorders” et “Dimproducts” 
from folder “Source Data”

3. Renommés les table en “Orders” et “Products”

4. Ajouter une colonne “ValeurVentes TVA inclus” dans
“Orders”

5. Ajouter une colonne “Description” avec resultats : pour 
P0001 : “Car-Crossover-Medium” dans “Products”

6. Ajouter une Colonne “ Margin” au query “Products”

7. Choisissez Home > Close & Load to …
1. Add to data model

8. Enregistrez le fichier: exercise_d2.xlsx



Exporter vers Excel



Close & Load (to…)

Home > Close & Load



Exporter vers Excel

• Excel Tables

• Power Pivot Data Model

• Only a connection

• PivotTable

• PivotChart

Avant

Maintenant



Ajouter au Data Model

• Pour charger les données vers le Data Mode, choisissez: 
• Only Create Connection

• Add this data to the Data Model



Changer l’emplacement par défaut de 
“Load to”

Load To…



Modifiez l’emplacement par défaut
“Load to”

File / Options and Settings

Data load



Transformations



Column from Examples

1. Créez un nouveau fichier

2. Choisissez Get Data > From File > From Workbook

3. Sélectionnez 2_C_01_data.xlsx

4. Sélectionnez la table Products

5. Sélectionnez la colonne Description

6. Cliquez sur Add Column > Column from Examples

7. Créez les examples suivants
1. 2e mot
2. 2e mot en CAPITALS
3. “Initials” sur la base de la première lettre de chaque mot 

8. Cliquez sur OK pour confirmer

Continuer 



Conditional column

1. Cliquez Add Column > Conditional column
1. Nom PriceRange

2. Conditions : High >15000, 
Normal>8000 sinon Low

2. Fermez le query et enregistrez le fichier 2_C_01.xlsx

Dbl-click



Transformations de dates

1. Créez un nouveau fichier

2. Sélectionnez Get Data > From File > From Workbook

3. Sélectionnez 2_C_02_data.xlsx

4. Ajoutez une colonne avec uniquement le Starttime

5. Créez plusieurs colonnes basées sur la colonne Start
1. Year, Quarter, Month

2. Monthname (Language!)

6. Créez un Custom Column Duration
1. =[End]-[Start]

2. Transform Total Minutes & Roundup



De texte vers colonne

1. Dupliquez le query précédent
• Les données viennent toujours de 2_C_02_data.xlsx

2. Supprimez toutes les colonnes sauf ID et Categories

3. Sélectionnez Split Column

4. Sélectionnez Split into Rows  (adv options)

5. Supprimez les espaces superflues avec Trim
• Transform > Format > Trim

6. Fermez les queries et enregistrez le fichier sous 
2_C_02.xlsx



Remove columns

• Remove Columns

• Choose Columns

Choose Columns

Remove Columns



Merge & Append Tables



Fusionner des tableaux

Situations:

• 2 listes indépendantes

• Tous les fichiers d’un dossier

• Plusieurs feuilles dans 1 workbook



2 listes indépendantes

1. Créez un nouveau fichier

2. Importez 2_D_01_data1.xlsx et 2_D_01_data2.csv

3. Fusionnez les queries moyennant
Append Queries as new

4. Appelez le query Contacts

5. Résolvez les problèmes; en renommant des colonnes

6. Fermez les queries, exportez que la liste fusionnée

7. Enregistrez le fichier sous 2_D_01



Tous les fichiers dans un dossier (m1)

1. Créez un nouveau fichier

2. Choisissez Get Data > From File > From Folder

3. Sélectionnez le dossier 2_D_02_data

4. Utilisez Combine pour fusionner via un example

5. Enregistrez le fichier sous 2_D_0201

Power Query 

Tips



All files from a folder(m2)

1. Créez un nouveau fichier

2. Sélectionnez Get Data > From File > From Folder

3. Sélectionnez the folder 2_D_02_data

4. Ouvrez le Query editor

5. Suivez les étape dans le Hand-out

6. Enregistrez le fichier sous 2_D_0202

Power Query 

Tips



Feuilles dans un fichier

1. Créez un nouveau fichier

2. Sélectionnez Get data > from file > from excel

3. Sélectionnez 2_D_03_data.xlsx

4. Sélectionnez le folder icon et Edit le query

5. Fusionnez les T_Order-Tables

6. Enregistrez le fichier sous 2_D_03



Étendre des tableaux 



Merge Tables avec des données
supplémentaires



Étendre des tableaux

1. Créez un nouveau fichier

2. Sélectionnez Get Data > From File > From Excel

3. Sélectionnez le fichier 2_D_04_data1.xlsx 
• Load to.. et Sélectionnez only a connection

4. Sélectionnez le fichier 2_D_04_data2.xlsx
• Load to.. et sélectionnez only a connection

5. Sélectionnez Get Data > Combine Queries > Merge

6. Sélectionnez les 2 queries et assortissez les colonnes

Suivant 



Étendre des tableaux

1. Dépliez la colonne DimProducts

2. Affichez uniquement: 
1. Productname

2. ProductCategory

3. ProductType

4. ProductCost

3. Enregistrez le fichier sous 2_D_04

Power Query 

Tips



Exercise Orders

1. Créez un fichier, importez 2_E_01_Orders.xlsx

2. Enregistrez le fichier sous 2_E_01

3. Supprimez les premières lignes de meta info

4. Créez de la ligne correcte le header row 

5. Eliminez "None" dans sendDate et InvoiceDate

6. Supprimez la ligne de synthèse "Totals“ en bas de la liste

7. Fermez le Query



Exercise employees

1. Créez un fichier, importez 2_E_02_Employees.xlsx

2. Enregistrez le fichier sous 2_E_02

3. Ajoutez le nom du manager à chaque ligne

4. Copiez le query et changez le nom: Managers 

5. Fusionnez le Employee query avec le Managers query

6. “Ouvrez” la colonne managers

7. Fermez le Query



Réutilisez méta info dans une colonne

1. Créez un nouveau fichier et importez
2_E_03_metainfo.xlsx

2. Enregistrez le fichier sous 2_E_03

3. Réutilisez la méta info suivant la méthode dans le hand-
out

4. Fermez le query

Power Query 

Tips



Date Table



Créer une Date Table dans M

• Dans BI, les données sont souvent comparées au niveau
du temps

• Pour ça, il nous faut une Dimension Date: une table 
comportant toutes les dates de notre modèle

1. Créez un nouveau fichier et enregistrez-le sous 2_E_04

2. Créez une Date Table suivant la méthode du hand-out 

Power Query 

Tips



Data Model



Modeling

• Avantages d’un Data Model

• Créer des relations

• Comprendre la direction du filtre

• Relations actives et inactives

• Calculated Columns

• COUNTROWS

• RELATED, RELATEDTABLE &  LOOKUPVALUE

• Tables mesure



Data Model

Dimensions Transactions Dimension Measures Support



Créer des relations - Démo

1. Ouvrez 3_A_01_Demo  (pbix / xlsx)

2. Allez vers l’affichage Diagramme

3. Drag & Drop les champs correspondants
Dimension Commandes
• Customerkey CustomerKey

• ProductKey ProductKey

• EmployeeID SalesRep

• Date OrderDate

• Date InvoiceDate



One-to-many

One - to - many

Chaque customer peut avoir beaucoup de 

commandes

Chaque commande appartient à un seul customer



Plusieurs relations (actives)

L’état d’activité d’une relation
est contrôlé avec la function :
USERELATIONSHIP

Double-clic



Relations

• En general, les relations ont la bonne direction
• one-many  (Dimension – Facts)

• Basée sur des valeurs uniques

• Au moins une des colonnes doit comporter des valeurs
uniques

• Plusieurs relations entre 2 tableaux si necessaire
• Seule une relation peut être active

• Des relations doubles n’existent pas
• créez une nouvelle colonne clé combinée



Direction filtre

Direction Filtre

Customers filtrent Orders

Orders ne peuvent PAS filtrer Customers

(voir 3_A_03_Demo_FilterDirection.xlsx )



DAX – Calculated columns

Data  
Analyses 
eXpression
Language



Data Analyses eXpression language

• DAX vous permet d’analyser et étendre des données
importées

• Fonctions Excel vs. Fonctions DAX

• Formules Excel réfèrent à des cellules

• Formules DAX réfèrent à des colonnes ou tableaux



Deux types de calculs

• Calculated Columns
• Calculs créés dans le Power Pivot Table

• Calculated Fields / Measures
• Synthèses ajoutées au PivotTable



Colonnes calculées

• Calculs exécutés dans le modèle de données

• Sont surtout utilisés comme filtre

• Utilisent de l’espace; les résultats sont enregistrés dans le modèle

• Calcul qu’en cas d’un Refresh

• Exemple

OrderDate OrderYear Function OrderYear

23/03/2016 2016 =YEAR( Orders[OrderDate])

15/04/2017 2017 =YEAR( Orders[OrderDate])



Règles pour références

Référer à une colonne

• Utilisez toujours le nom de la table =YEAR( 
Orders[OrderDate] )

OrderDate OrderYear Function OrderYear

23/03/2016 2016 =YEAR( [OrderDate] )  

28/02/2018 2018 =YEAR( Orders[OrderDate] )



Astuces pour formuler des fonctions

• Tapez vos fonctions, tableaux, colonnes et mesures

• Utilisez les <> <> pour sélectionner

• Utilisez les <TAB> pour confirmer la sélection

• Utilisez <ENTER> pour terminer la saisie

• Ajoutez des espaces après NOMFONCTION ( et avant les )

• Ajoutez fin de règle via <SHIFT>+<ENTER>

• Excel 2016+ utilisez <TAB> pour augmenter le retrait

• Utilisez // pour ajouter un commentaire dans le formule



DAX Code

=SUMX(FILTER(Orders; Orders[SalesType] IN {“Phone”,”Call”}) ; 
Orders[UnitPrice]*Orders[Quantity]))

=SUMX( 
FILTER( 

Orders; 
Orders[SalesType] IN {“Phone”,”Call”}
) ;

Orders[UnitPrice]*Orders[Quantity]
)

)



Calculated columns



Calculated Columns in Excel

• Faites un clic droit sur une colonne et sélectionnez Insert 
Column

• Faites un clic droit sur le nom pour l’ajuster
• Les espaces et d’autres caractères spéciaux sont autorisés

• Tapez le formule dans la barre de formule

• Cliquez sur  ou <ENTER> pour confirmer



Transformations OrderDate

Ouvrez 3_B_01_CalculatedColumns

• Calculez l’Année du OrderDate : OrderYear
=YEAR(  Orders[OrderDate]  )

• Calculez le mois du OrderDate : OrderMonth
=MONTH(  Orders[OrderDate]  )



Calculations

Dans  3_B_01_CalculatedColumns

• Définissez le trimestre du OrderDate: OrderQuarter
=ROUNDUP(  Orders[OrderMonth] / 3 ; 0 )

• Définissez le total par ligne: Line Total
= Orders[Quantity]* Orders[PricePerUnit]



Utilisez vos relations

• Deux tableaux sont relies via la relation one-many
Fonction RELATED

• Un tableau FACT recherche son info du tableau DIM

• Une valeur est retournée

Fonction LOOKUPVALUE

• Une relation ne doit pas exister

• Une valeur est retournée

Fonction RELATEDTABLE

• Un tableau DIM recherche son info du tableau FACT

• Une table de résultats est retournée



RELATED

Dans 3_B_01_CalculatedColumns

• Ajoutez ProductName au tableau Commandes: 
ProductName

=RELATED(  Product[ProductName]  )

• Calculez la marge par ligne: Line Margin

= Orders[Quantity] * 
( Orders[PricePerUnit] – RELATED(Products[ProductCost] )



LOOKUPVALUE

Dans 3_B_01_CalculatedColumns

• Ajoutez le nom du manager à chaque employé dans le 
tableau Employee : Manager

=LOOKUPVALUE(
Employees[Name] ; 
Employees[EmployeeID]; 
Employees[ReportsTo] 
)



RELATEDTABLE

Dans 3_B_01_CalculatedColumns

• Dans le tableau Customers la colonne est présente Orders
= COUNTROWS( Orders )
Le résultat n’est pas correct. Pourquoi?

• Créez une nouvelle colonne correcte: Orders Rows
= COUNTROWS ( 

RELATEDTABLE( Orders )
)



Exercise

1. Ouvrez 3_B_02_Columns

2. Calculez pour chaque Commande le rabais en 
comparant le Catalogprice (dans Products) avec le
PricePerUnit (dans Orders)
• Nom de la colonne : Discount abs

• Modifiez la mise en forme en: Decimal Number (2 decimaux)

3. Comptez le nombre de lignes de commande pour 
chaque produit
• Nom de la colonne: Order Lines



DAX

Data  
Analyses 
eXpression
Language



Deux types de calcul

• Calculated Columns
• Calculs créés dans le Power Pivot Table

• Calculated Field / Measures / Mesures
• Synthèses ajoutés au PivotTable



Measures

• Synthèses (aggregations) dans la PivotTable

• Peuvent uniquement être utilisées comme aggrégation

• Se servent de puissance de calcul

• Example
• =COUNT( Orders[OrderID] )



Tableau Measure



Où enregistrer une mesure

• Mesures peuvent être enregistrés dans chaque tableau de 
votre modèle

• On n’utilise jamais le nom de l’emplacement (table) quand
on réfère à une mesure

• Dans Power BI il est possible de déplacer des mesures, 
dans Power Pivot non



Tableau mesure

Enregistrez toutes les mesures dans un tableau séparé

Avantages

• Toutes les mesures dans un emplacement

• Quand un tableau est supprimé et rajouté, les mesures ne 
sont pas perdues

Désavantages

• Dans Excel il n’est plus possible de naviguer
par clic vers les details dans une PivotTable



Créez une table mesure dans XLSX

1. Copiez 4-6 colonnes et 2 lignes dans Excel

2. Allez au modèle de données

3. Cliquez sur des données existantes (non dans la zone 
mesure donc)

4. Cliquez sur le bouton Paste

5. Tapez un nom, p.ex. “Analysis”

• Sélectionnez toutes les colonnes, faites un clic droit et 
sélectionnez “Hide from client tools”



Créer une table mesure

1. Ouvrez 4_A_01_Demo

2. Copiez une zone vide de 2 colonnes et 6 lignes

3. Allez au Data Model

4. Cliquez sur données existantes

5. Collez comme nouvelle table 

6. Tapez un nom: “Analyse”

1/ Cliquez ici

2/ Collez ici



Aggrégations -base



Créer des mesures dans Excel

• Allez à la table où la mesure doit être
créée

• Cliquez dans la moitié basse de l’écran

• Tapez la mesure dans la barre des 
formules

1/ Cliquez ici

2/ Tapez ici



Aggrégations - base

• Fonctions
• SUM, MAX, MIN …
• COUNT, COUNTA, DISTINCTCOUNT …
• COUNTROWS
• AVERAGE, STDEV.P, STDEV.S …

• Ces fonctions rassemblent beaucoup les fonctions dans 
Excel

• Seul un argument: TableName ou ColumnName
• COUNTROWS( TableName )
• SUM( TableName[ColumnName] )



Fonctions COUNT/SUM

• Ouvrez 4_A_01_Demo

• Calculez le nombre de commandes: Order Lines
=COUNTROWS( Orders )

• Déterminez le nombre de clients qui ont fait une
commande : Actual Customers

=DISTINCTCOUNT( Orders[Customerkey] )

• Déterminez la somme de la quantité commandée : 
Quantity Total

=SUM( Orders[Quantity] )



Créez une PivotTable

• Créez une simple PivotTable avec les mesures

• Affichez les valeurs verticalement

• Créez une répartion par Customercountry

• Ajoutez un slicer pour le ProductCategory

• Faites de sorte que l’ampleur de la colonne ne soit pas 
changée lors d’une mise à jour

1. PivotTable Tools / Analyze / PivotTable / Options

2. Change column width on update



AVERAGE et STDEV

• Dans 4_A_01_Demo

• Calculez la moyenne de la quantité commandée : 
Quantity Avg

=AVERAGE( Orders[Quantity] )

• Calculez la deviation par défaut de la quantité
commandée: Quantity StDev

=STDEV.P( Orders[Quantity] )

• Utilisez les mesures dans une (Pivot)Table en combinaison
avec CustomerCountry



Expressions agrégeantes



Expressions agrégeantes

• Functions
• SUMX, MAXX, MINX, AVERAGEX, STDEVX.P, STDEVX.S …

Arguments

• Expressions dans la fonction

• SUMX( Orders;

[Prix]*[Number] )

• Ou des tableaux temporaires
• AVERAGEX(

TOPN( 10 ; Customers ; [turnover] );

[turnover] )



SUMX

• Ouvrez 4_B_01_Demo

• Valeur des commandes (prix*nombre) : Total Orders
=SUMX( Orders;

Orders[Quantity] * Orders[PricePerUnit] )

• Valeur Taxe: Total TVA
=SUMX( Orders;

Orders[Quantity] * 
Orders[PricePerUnit]*Orders[BtwTvaVat] )

• Total Orders incl TVA
= [Total Orders] + [Total orders TVA]



SUMX - Défi

• Calculez la marge totale : Total Margin
Astuce: SUM( Quantity*( Price-Cost ) )

=SUMX( Orders;  
[Quantity] 
* (

[PricePerUnit] - RELATED( Products[ProductCost] )
)

)

• Créez une PivotTable affichant ces valeurs par 
CustomerCountry



FILTER()

• FILTER() est une function de table; le résultat est une table

• FILTER( Table ; Filter )

FILTER(Orders; Orders[Status]=“Cancelled”)

Crée une table comportant toutes les Commandes
Cela ne peut jamais être la réponse finale de la mesure



Cancelled Deals

• Somme des Cancelled Deals : Total Cancelled Deals

=SUMX( 
FILTER(  Orders ; 

Orders[Status]=“Cancelled”
) ;

Orders[Quantity] * Orders[PricePerUnit] 
)



Closed Deals

• Somme des closed Orders: Total Sales

= SUMX( 
FILTER(  Orders ; 

Orders[Status]=“closed”
) ;

Orders[Quantity] * Orders[PricePerUnit] 
)

• Extra: créez une mesure pour déterminer Success Rate
= [Total Sales] / [Total Orders]



Nombre moyen de jours jusqu’à livraison

• Average Days to delivery =
AVERAGEX( Orders; 

Orders[Senddate]-Orders[Orderdate] )

• Average Days to delivery =
AVERAGEX( 

FILTER(  Orders ; 
Orders[Senddate]<> BLANK()

) ;
Orders[Senddate]-Orders[Orderdate] )

Résultats étranges



Calculate



CALCULATE

• CALCULATE modifie les filtres appliqués

• Structure: CALCULATE( expression ; Filter1 ; Filter2 …)
• Filter: colonne = valeur fixe

• =, <, >, <=, >= en <>

• Fonctions Filter : ALL, ALLEXCEPT, SAMEPERIODLASTYEAR…

Examples
• Count Orders= 

CALCULATE( COUNTROWS( orders) ;
Orders[Status]=“Closed” )



Sales per Type

• Total Sales via Internet: Total Sales Internet

= CALCULATE( [Total Sales]
; Orders[SalesType] = “web“ )

• Total Sales via Internet: Total Sales Walk-in 

= CALCULATE( [Total Sales]
; Orders[SalesType] = “Visit“ )



Arguments

• = égale

• && AND logique

• || OR logique

• Total Sales BeNeLux= 
CALCULATE( [Total Sales]; 

Customer[Country]=“BE”     ||
Customer[Country]=“LUX”   ||
Customer[Country]=“NL” )



Sales per Type

• Total Sales par téléphone: Total Sales Call
Total Sales Calls=

CALCULATE( [Total Sales]
; Orders[SalesType] = “Call“
|| Orders[SalesType] = “Phone“)



Résultats par SalesType

• Share Walk-in to Total Sales: Share Walk-in

= DIVIDE( [Total Sales Walk-in ] ; 
[Total Sales] 

)



Fonctions Filtre: ALL

• ALL annule tous les filtres appliqués à la mesure

• De cette manière on peut faire des GrandTotals, qui sont
importants pour calculer Percentages

Arguments

• ALL( TableName )

• ALL( TableName[ColumnName] )



Shares per ProductType/Category

• Calculez les Ventes Totales de tous les produits

Total Sales All Products
= CALCULATE( [Total Sales];

ALL( Products )
)

• Calculez le Share de tous les produits
Share Per Product

=DIVIDE( [Total Sales];
[Total Sales All Products];
BLANK() 
)



Country Comparison 

• Créez Total Sales all Countries
= CALCULATE( 

[Total Sales] ; 
All( Customers[CustomerCountry] )
)

• Créez Share Per Country 
= DIVIDE( [Total Sales] ; [Total Sales all Countries] )



ALLEXCEPT()

• ALLEXCEPT annule tous les filtres, sauf …

• Créez Total Sales per Year
= CALCULATE( 

[Total Sales] ; 
ALLEXCEPT( Dates; Dates[Year] )
)

• Créez Share per Year
= DIVIDE (  [Total Sales] ;

[Total Sales per Year]

)



USERELATIONSHIP()

• S’il y a plusieurs relations entre 2 tableaux, seule une sera 
active

• USERELATIONSHIP active une relation existante inactive



Total Invoiced

• Créez une mesure calculant le montant facturé dans une
certaine période.  Total Invoiced

• Total Facturé
Total Invoiced =
CALCULATE( [Total Sales];

USERELATIONSHIP( 
Dates[date] ; Orders[InvoiceDate]  )
)

• Évaluez le résultat dans une PivotTable avec
Total Sales et Total Invoiced 
groupé par Années et Mois



Limites de CALCULATE

• Néant, sauf...
• Il y a des méchanismes pour garantir la performance
• Les filtres ne peuvent donc pas être trop complexes, comme

• Column = Measure

• Column = Formula

• Column = Column

• Measure = Measure

• =, <, >, <=, >= and <>

• Ce qui ne marchera pas:
• Sales late delivered = 

CALCULATE( [Total Sales]
; Orders[SendDate]-Orders[Orderdate] > 5
)

Mais pour ça, on a FILTER()



FILTER()

• FILTER() annule la protection

• FILTER() est une fonction de table, résultat: une table

• FILTER( Table ; Filter )

• Sales late delivered = 
CALCULATE( [Total Sales]

; FILTER( Orders
; Orders[SendDate]-Orders[Orderdate] > 5 )

)



CALCULATE avec/sans FILTER

• Actual Orders =
CALCULATE(  [Deals Expected]

; Orders[Status] = “Closed“ )

• Actual Filtered Orders =
CALCULATE(  

[Deals Expected]
;FILTER (Orders 

; Orders[Status] = “Closed“ )
)

Modifie le filtre Filtre la table



Intelligence de Dates



Intelligence de dates

• Fonctions d’intelligence de dates
• TOTALYTD, TOTALQTD, TOTALMTD (running totals)
• SAMEPERIODLASTYEAR
• DATEADD
• …

• Pour fonctionner, ces fonctions ont besoin d’une
dimension; une Date Table

• La Date Table doit être reliée à toutes les dates dans la 
facts table



Date Table 

• Une colonne clé comportant des dates

• Il est nécessaire que toutes les dates dans la période de 
référence existent
p.ex. toutes les dates entre 1/1/2010 et 31/12/2020

• Power Pivot: Design/ Mark as Date table

• Power BI: Modeling / Mark as Date table

• Il est possible d’ajouter plus d’info
• Année, n° semaine, EstJourOuvrable, Nom du mois…



Comment créer une Date Table

• Une Date Table peut être créée
• Importée comme les autres sources

• Calculée dans Power Query via M
• Voir notes

• Calculée dans DAX (uniquement Power BI)



Étapes

1. Importez la Date table

2. Sélectionnez Modeling / Mark as Date Table
1. Sélectionnez la colonne clé

3. (Désactivez la Default summarization pour ces colonnes)

4. Triez le Month Name avec le Month (numéro)

Default Summarization

Sort by Column



Importer une Date Table

• Ouvrez 4_D_01_DateIntel

• Créez une Data Table contenant le code M code 
4_D_01_M_DataTable.txt

• Modifiez le nom de la table: Dates

• Indiquez que la table est une Date Table

• Après le chargement des données dans le modèle
• Modifiez l’ordre de triage des colonnes

• Month Name, mmmYYYY, mm YYYY en mmm

• Désactivez le default summarization pour (uniquement Power BI):
• Year, Quarter and Month

• Cachez la colonne Monthkey

• Utilisez Year, Quarter et Month Name dans le visual



TOTALYTD()

• Crée un total progressif (par année calendaire)

• Arguments
• TOTALYTD( Expressie;DateTable[DateColumn] )

Exemple

• OrderCountYTD:=
TOTALYTD( COUNTROWS( Orders );

Dates[Date] )

Clé date



Total Sales YtD

• Ouvrez 4_D_02_DateCalculations

• Créez un YtD pour les ventes totales existantes : Total Sales
YtD

• =TOTALYTD( [Total Sales] ; Dates[Date] )

• Ajoutez Total Sales YtD
au visual/
PivotTable



DATESYTD()

• Crée une table comportant toutes les données jusqu’à la 
dernière date dans le context de l’année sélectionnée

• Arguments
• DATESYTD(DateTable[DateColumn] )

• Donc Total Sales YtD peut être noté comme:
= CALCULATE (

[Total Sales] ;
DATESYTD( Dates[Date] )
)



DATESBETWEEN()

• Crée une table comportant toutes les dates entre 2 dates 
spécifiées

• Arguments
• DATESBETWEEN(DateTable[DateColumn] ; Startdate ; Enddate )

• Total Sales to Date peut donc être noté comme:
= CALCULATE (

[Total Sales] ;
DATESBETWEEN( Dates[Date];

DATE( 1900 ; 1; 1) ;
MAX( Dates[Date] )
)

)



Total YtD with DATESBETWEEN()

• Total Sales YtD peut donc être noté comme:
= CALCULATE (

[Total Sales] ;
DATESBETWEEN( Dates[Date];

DATE ( YEAR ( MAX ( Dates[Date] ) ), 1, 1 ),) ;
MAX( Dates[Date] )
)

)



Total Quantity to Date

Total Quantity 
= SUMX(FILTER( Orders; Orders[Status]= "closed"); Orders[Quantity] )

Total Quantity To Date 
= CALCULATE(

[Total Quantity ];
DATESBETWEEN( Dates[Date];

DATE( 1900 ; 1; 1) ;
MAX( Dates[Date] )
)

)



Total Delivered to Date

Quantity Delivered
= SUM( Deliveries[Quantity] )

Total Delivered To Date 
= CALCULATE(

[Quantity Delivered ];
DATESBETWEEN( Dates[Date];

DATE( 1900 ; 1; 1) ;
MAX( Dates[Date] )
)

)



Total Stock

• Créez une mesure déterminant le total du stock au début 
• Qty Stock Start = SUM( Products[ProductStockStart] )

• Créez une mesure déterminant l’état actuel du stock
• Total Stock = [Qty Stock Start]  +  [Total Delivered To Date ]

- [Total Quantity To Date] 

• Créez une table affichant cette info par mois

• Ajoutez un segment (slicer) pour l’année



Total Stock



SAMEPERIODLASTYEAR

• Calcule une mesure pour la période il y a un an 

• Période souhaitée
• Actual Orders = CALCULATE(  [Deals Expected] ; Orders[Status] = 

“Closed“ )

• Même période il y a un an: Actual Orders -1Year
• Actual Orders -1Year= 

CALCULATE(
[Actual Orders ] ;

SAMEPERIODLASTYEAR(
Dates[date]

)
)



Turnover Previous Year

• Calculez les ventes totales de la même période il y a un 
an: 
Total Sales-1Year

=CALCULATE( [Total Sales];
SAMEPERIODLASTYEAR( Dates[Dates] ) )

• Créez une PivotTable

• Calculez la croissance année après année : Total Sales 
YoY

=DIVIDE(  [Total Sales] - [Total Sales -1year] ;
[Total Sales -1year] ;
BLANK()
)



DATEADD()

• DATEADD(Dates; nbr Intervals; Interval)

• Calculez les ventes totales d’il y a 2 ans moyennant
DATEADD : Total Sales -2Years

=CALCULATE( [Total Sales]
; DATEADD( Dates[Date]

; -2 
; Year ) 

)

In
te

rv
a
ls

YEAR
QUARTER
MONTH

DAY



Total Sales -1Q

• Calculez les ventes totales de la période sélectionnée un
trimestre précédent : 

Total Sales -1Q
=CALCULATE( [Total Sales]

; DATEADD( Dates[Date] ) 
; -1
; Quarter 

)

Total Sales QoQ

=DIVIDE(  [Total Sales] - [Total Sales -1Q] ;
[Total Sales -1Q] ;
BLANK()
)



PARALLELPERIOD()

• PARALLELPERIOD(Dates; nbr Intervals; interval )
• Affiche le total de la période précédente

In
te

rv
a
ls

YEAR
QUARTER
MONTH

DAY

TotalSales-1Y parallel = 
CALCULATE( [Total Sales]; 

PARALLELPERIOD( Dates[Date] 
;-1; YEAR ) 
)



Currency Reporting

EXTRA



Complexité

• Totaux de colonne ne sont plus utiles

• Exchange rates changent sans cesse

• Dynamic reporting avec devises différentes

EXTRA



Solution 1: Somme conditionnelle

• Contrôlez s’il n’y a qu’une devise sélectionnée

• Importez une table

• Sales Amount = 
IF( HASONEVALUE( Currencies[Currency] )

; SUMX( 
Orders 
; Orders[Quantity] * Orders[PricePerUnit] 

)
) 

EXTRA



Solution 2:  Cherchez le dernier taux de 
change

• Créez une colonne séparée pour 
la valeur procédée
!!! Aussi possible avec une mesure

• Importez une table avec les taux de 
change

EXTRA



• LatestRatetoEUR = 
LOOKUPVALUE( CurrencyRates[AvgRate] 

; CurrencyRates[CurrencyFrom] ; Orders[CurrencyCode] 
; CurrencyRates[CurrencyTo] ; "EUR“
; CurrencyRates[Date] ; MAX( CurrencyRates[Date] 
)

EXTRA

Solution 2:  Cherchez le dernier taux de 
change



Solution 2: Convert to actual EURO

• ActualRatetoEUR = 
LOOKUPVALUE( CurrencyRates[AvgRate] 

; CurrencyRates[CurrencyFrom] ; Orders[CurrencyCode] 
; CurrencyRates[CurrencyTo] ; "EUR“
; CurrencyRates[Date] ;

// retrieve the Actual Date by filtering the table
CALCULATE( MAX(CurrencyRates[Date] )

// remove any filter on the CurrencyRates table
; ALL( CurrencyRates )

// At this point you are in a new table, you can't simply rever to Orders[OrderDate]
// use EARLIER to indicate you wish to use the same orderdate as earlier,
// like before you went into the CALCULATE

; CurrencyRates[Date] <= EARLIER( Orders[Orderdate])
; CurrencyRates[CurrencyFrom] = EARLIER( Orders[CurrencyCode] )
)

)

EXTRA



BucketLists

EXTRA



BucketLists

• BucketLists vous permet de grouper les clients … sur la 
base de totaux

• Buckets sont crées comme colonne calculée

EXTRA



Chiffre d’affaires par client

• Calculez le Chiffre d’affaires par client (calculez la 
colonne)
• =SUMX( RELATEDTABLE( Orders );

[Quantity]*Orders[PricePerUnit] )

• Groupez le chiffre d’affaires moyennant SWITCH
chiffre d’affaires < 300000 : Bronze
chiffre d’affaires < 500000 : Argent
chiffre d’affaires >= 500000 : Or
• =SWITCH( TRUE(); [Omzet]<300000;"1.Bronze";

[Omzet]<500000;"2.Argent";
"3.Or" )

EXTRA



References & Guides



Manuel Power Pivot 

• Henk Vlootman & Michiel
Rozema

• Néerlandais

• Focus
• Power Pivot

• DAX fonctions

• Inconvénient(s)
• Power Query

• Power BI



Manuel Power BI

• Peter ter Braake

• Néerlandais

• Focus 
• Le processus BI entier

• Exemples pratiques

• Inconvénient(s)
• In-depth DAX



Dashboarding & 
reporting with Power 
Pivot and Excel 
• Kasper de Jonge

• Anglais

• Focus
• Projet end to end

• Bon pour les débutants

• Inconvénient(s)
• Power BI manque

TOP



Power Pivot 
and Power BI

• Rob Collie & Avichal Singh

• Anglais

• Points positifs
• Débutants jusqu’à avancé

• Toutes les versions

TOP



Power Query for 
Power BI and Excel

• Chris Webb

• Anglais

• Focus
• Power Query

• Inconvénient(s)
• Exemples réalistes



Collect, Combine and 
Transform Data using 
Power Query in …

• Gil Raviv

• Anglais

• Focus
• Power Query

• Livre d’exercises

• Inconvénient(s)

TOP



Pro Power BI Desktop

• Adam Aspin

• Anglais

• Focus
• Le processus entier

• Inconvénient(s)
• Parfois les boutons sont expliqués



The Definitive Guide 
to DAX

• Alberto Ferrari & Marco Russo

• Anglais

• Focus
• Power Pivot DAX

• Inconvénient(s)
• Power BI

• Power Query

TOP



Analyzing Data with 
Microsoft Power BI and 
Power Pivot for Excel

• Alberto Ferrari & Marco Russo

• Anglais

• Focus
• Advanced DAX & Data model

• Inconvénient(s)
• Difficile

TOP



Sur le Web



Blogs

• https://docs.microsoft.com/en-us/power-bi/
• Official Documentation

• https://powerbi.microsoft.com/en-us/blog/
• Official Blog (What’s new)

• http://www.Power Pivotpro.com/
• Rob Collie

• https://www.sqlbi.com/
• Marco Russo and Alberto Ferrari

• https://www.kasperonbi.com/
• Kasper de Jonge

http://www.powerpivotpro.com/
https://powerbi.microsoft.com/en-us/blog/
http://www.powerpivotpro.com/
https://www.sqlbi.com/
https://www.kasperonbi.com/


Online resources

• www.daxformatter.com

• https://dax.guide

http://www.daxformatter.com/
https://dax.guide/


Questions & Réponses



Peter De Laet

Formateur

Peter.delaet@learnia.be
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