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What is Business Intelligence



Business Intelligence

Definition
The term Business Intelligence (BI) refers to technologies, applications and 

practices for the collection, integration, analysis, and presentation of 
business information. 

The purpose of Business Intelligence is to support better business decision 
making. 

https://en.wikipedia.org/wiki/Business_intelligence

https://en.wikipedia.org/wiki/Business_intelligence


Process

Discovery Transformation Modelling Analysis Visualization
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1. Collect/Discover data from various systems

2. Transform and uniform the data

3. Model your data by creating relations between various tables

4. Analyse the data

5. Visualize the data



What is Power BI



Microsoft self service BI

• Power BI Desktop & PowerBI.com

But also…

• A set of Add-ins for Excel
• Power Pivot

• Power Query

• 3D Maps (aka Power Map)

• Power View



Power Pivot

Self-service-BI
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Power Query

Power BI Desktop

Excel

Power Query

Discovery Transformation Modelling Analysis Visualization



Microsoft Self-service-BI
Power BI =

1. An online platform
with a supporting desktop application

2. Set of add-ins for Excel 
(Power Pivot, Power Query …)

Both are independent but are using similar techniques
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Getting started with Power BI



Power BI Desktop vs Online

Power BI Desktop is a staging tool, designed to create reports 
that need to be published on PowerBI.com

PowerBI.com reports

• Are read-only for consumers

• Are editable for you (although you better not)

• Can automatically be refreshed



Download

• From Microsoft Store / Software Centre

• Search for Power BI

• Sign in/up after installation



Help and resources

More resources at the end of the slideshow

Help



Report

Data

Model

Filter

Visuals

Tables



Use Reports

…Sort

Focus



Online

Apps

Workspaces



Online Workspace

Reports

Datasets



Elements

• Dashboards
• Overview of all your important visuals

• Reports
• Your reports

• Workbooks
• Shared Excel Files

• Data sets
• The data models used to create reports



Consuming Online Reports



Create a report



Start a new Power BI report

• Start Power BI Desktop
• Per session there is one PBIX-file

• Power BI Desktop can run multiple sessions simultaneously 

• Never without PBIX

• Save the file as QuickRun.pbix



Power BI Desktop

Self-service-BI
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Power Query

Discovery Transformation Modelling Analysis Visualization



Power BI - Demo



DEMO

1. Load the data from Source Data / Orders.xlsx

2. Select the sheet “Orders”

3. Click on Load

4. Switch to the Data view

5. Check the datatypes

Data

Data type

Format



Exercise
• Load customers from Source Data / DimCustomers.xlsx

• 3 times the same data
• Select the Excel Table

• Change the name to “Customers”

• Load products from the file Source Data / Products.xlsx
• 3 different sheets
• Select all sheets

• Check and fix the queries
• Category, the first row is not recognized
• Subcategory, the first row is not recognized
• Home/ Transform data



Power Query – fix de headers

Transform data

Use First row as Headers

Queries

Close & Apply



Modelling

Power BI will try to create the relations

Model



Create a chart

Stacked column

Country

Category

Quantity

Report



Save and close the file

Save Close



Power Query - Intro



Power Query Data sources

• Power Query can handle 45+ data sources in Power BI

• Power Query can handle 25+ data sources in Excel



Power Query

• Extract the data 

• Transforms the data
• Format, Remove rows, UnPivot, Date2Month … 

• Merges data
• Import from folder, replace …

• Loads the data into your model



Example

1. Create a new Excel File

2. Use Data/ Get Data / From File  2_A_01.xlsx

3. Select column 1-3

4. Transform/ Unpivot other columns

5. Rename the columns “Attribute” and “Value”

6. Change the datatype

7. …

8. Home > Close and Load



Power BI – Query interface

Get Data

Refresh

Edit Queries



Get Data
Get Data

More



Interface

• Formula Bar
• View/ Layout/  Formula Bar

• Transform-tab
• Change the selected column

• Add column-tab
• Create a new column by transforming the selected column

• Buttons have “secret” options



Unpivot Columns

• Transform/ Unpivot Columns

Unpivot Columns / Unpivot other columns



Data connections



External Excel files into Excel

1. Create a new file

2. Get Data > From File > From Workbook

3. Select 2_B_01_data.xlsx

4. Select 
• The Table tbl_Products

• The Sheet Production

5. Tbl_products: Split the column Description

6. Production: Fill the missing years

7. Home > Close & Load



Text/CSV-Files

1. Create a new Excel file

2. Get Data > From File > From Text/CSV

3. Select B_02_data.csv

4. Close the query



Text/CSV-Files
1. Create a new file

2. Get Data > From File > From Text/CSV

3. Import 2_B_03_data.txt

4. Promote the first row
The Startdate is not correctly recognized
• File > Options & Settings > Query options > Regional settings

English: United States

• Or use Add Column / Column from Example

5. Refresh Preview

6. Change the datatype of Startdate

7. Close the query



Databases

• Multiple databases are supported
• Get Data > From Database

• Via ODBC connections the support can be 
extended
• Get Data > From Other Sources



Demo MYSQL/SQL 

1. Get Data > From Database > From MySQL Database

2. Address and Database name

3. Username and password

4. Select Tables

5. …



Access

1. Create a new File

2. Get Data > From Database > From Microsoft Access …

3. Select 2_B_04_data.accdb or 2_B_04_data_alternative.accdb 

4. Search and import Purchase orders or Orders

5. …

6. Close the query

Because of a version mismatch between the Access file and your version of Excel/Power BI, the import could fail. 

https://docs.microsoft.com/en-us/power-bi/desktop-access-database-errors

https://docs.microsoft.com/en-us/power-bi/desktop-access-database-errors


Transformations



Column from Examples
1. Create a new file

2. Get Data > From File > From Workbook

3. Select 2_C_01_data.xlsx

4. Select the table Products

5. Select the column Description

6. Click Add Column > Column from Examples

7. Create the next 3 examples
1. 2e word

2. 2e word in CAPITALS

3. “Initials” based on the first character of every word

8. Click OK to confirm

Continue 



Conditional column

1. Click Add Column > Conditional column

1. Name PriceRange

2. Critaria: High >15000, 
Normal>8000 else Low

2. Close the query and save the file as 2_C_01.xlsx 



Date transformations
1. Create a new file

2. Get Data > From File > From Workbook

3. Select 2_C_02_data.xlsx

4. Add a column containing only the Starttime

5. Create multiple columns based on the column Start
1. Year, Quarter, Month
2. Monthname (Language!)

6. Create a Custom Column Duration
1. =[End]-[Start]
2. Transform Total Minutes & Roundup



From Text to column

1. Duplicate the previous query

• the data is still coming from 2_C_02_data.xlsx 

2. Delete all columns except ID and Categories

3. Choose Split Column

4. Choose Split into Rows (adv options)

5. Remove redundant spaces using Trim

• Transform > Format > Trim

6. Close the queries and save the file as 2_C_02.xlsx 



Append Tables



Appending Tables

Situations

• 2 Separate lists

• All files from a folder

• Multiple sheets from 1 workbook



2 Separate lists

1. Create a new file

2. Import 2_D_01_data1.xlsx and 2_D_01_data2.csv

3. Append these 2 queries using
Append Queries as new

4. Call the query Contacts

5. Solve the issues, by renaming the columns

6. Close the queries, export only the combined list

7. Save the file as 2_D_01



All files from a folder

1. Create a new file

2. Get Data > From File > From Folder

3. Select the folder 2_D_02_data

4. Use Combine to combine the data by example

5. Save the file as 2_D_0201



Sheets from 1 file

1. Create a new file

2. Get data > from file > from excel

3. Select 2_D_03_data.xlsx

4. Select the folder icon and edit the query

5. Combine the T_Orders…-Tables

6. Save the file as 2_D_03



Power Query - Exercises



Exercise Orders

1. Create a new file and import 2_E_01_Orders.xlsx

2. Save the file as 2_E_01

3. Remove the first rows with meta info

4. Turn the correct row into the header row

5. Remove "None" in sendDate and InvoiceDate

6. Remove the summary "Totals“ rows at the bottom

7. Close the query



Reuse meta info as a column

1. Create a new file and import 2_E_03_metainfo.xlsx

2. Save the file as 2_E_03

3. Reuse the meta info using the method from the handout

4. Close the query



Part 2 : Modelling



Data Model

Dimensions Transactions Dimension Measures Support



Create relations - Demo

1. Open 3_A_01_Demo

2. Go to the diagram view

3. Drag & Drop corresponding fields
Dimension Orders
• Customerkey CustomerKey

• ProductKey ProductKey

• EmployeeID SalesRep

• Date OrderDate

• Date InvoiceDate



One-to-many

One - to - many

Each customer can have many orders

Every order belongs to one customer



Multiple (active) relations

Being active is 
normally controlled via 
the function: USERELATIONSHIP

Dbl-click



Relations

• Relationships have the right direction by default 
• one-many  (Dimension – Facts)

• Based on unique values in columns

• At least one of the columns should contain unique values

• Multiple relations between 2 tables if needed

• But only one can be active

• Double relations do not exist
• Create an additional combined key-column



Filter direction

Filter direction

Customer can filter Orders

Orders can not filter Customers



DAX – Calculated columns

Data  
Analyses 
eXpression
Language



Data  Analyses eXpression language

• DAX allows you to analyse and to extend your imported data.

• Excel vs DAX functions

• Excel formulas refer to cells and ranges

• DAX formulas refer to columns or tables



Two types of calculations

• Calculated Columns
• Calculations made in the data model table

• Measures (Calculated Field)
• Summaries(aggregations) added to the PivotTable



Calculated Columns

• Calculations made in the data model table

• Are mainly used as a filter

• Use space; results are saved in the data model

• Recalculated on Refresh

• Example
OrderDate OrderYear Function OrderYear

23/03/2016 2016 =YEAR( Orders[OrderDate])

15/04/2017 2017 =YEAR( Orders[OrderDate])



Referencing conventions

Referring to a column

• Always include the table name =YEAR( Orders[OrderDate] )

OrderDate OrderYear Function OrderYear

23/03/2016 2016 =YEAR( [OrderDate] )  

28/02/2018 2018 =YEAR( Orders[OrderDate] )



Writing tips
• Type your functions, tables, columns and measures

• Use the <> <> to select

• Use the <TAB> to confirm your selection

• Use <ENTER> to confirm your calculation

• Additional space after a FUNCTIONNAME( 
additional space before )

• Add line breaks using <SHIFT>+<ENTER>

• Use <TAB> to add whitespace

• Type // or -- to add comments in your formula



DAX Code

=SUMX(FILTER(Orders; Orders[SalesType] IN {“Phone”,”Call”}) ; 
Orders[UnitPrice]*Orders[Quantity])

=SUMX( 
FILTER( 

Orders; 
Orders[SalesType] IN {“Phone”,”Call”}
) ;

Orders[UnitPrice]*Orders[Quantity]
)



Calculated columns



Calculated Columns in Power BI

• Right-click on a column and select New Column

• In the formula bar type the name in front of the =
• Spaces and some special characters are allowed

• Enter the formula in the formula bar

• Click  or press <ENTER> to confirm



OrderDate Transformations

Open 3_B_01_CalculatedColumns

• Show the year of the OrderDate: 
OrderYear
=YEAR(  Orders[OrderDate]  )

• Show the month of the OrderDate: 
OrderMonth
=MONTH(  Orders[OrderDate]  )



Calculations

In  3_B_01_CalculatedColumns

• Show the quarter of the OrderDate: 
OrderQuarter
=ROUNDUP(  Orders[OrderMonth] / 3 ; 0 )

• Show the line total : 
Line Total
= Orders[Quantity]* Orders[PricePerUnit]



IF … Then … else
1. Create a CostRange column

2. Click Add Column > Conditional column
1. Name CostRange
2. Requirements : High >15000, 

Normal>8000 
else Low

• =IF ( Products[ProductCost]> 15000 ; 
"High" ;  
IF( Products[ProductCost] > 8000 ; 

"Normal" ; 
"Low") 
)



SWITCH

• Nested-IFs are hard to control
Therefore use SWITCH

• MAxDiscount
=SWITCH ( Order[SalesType] ; // the test

“Web” ; 15% ;  //Current value; answer
“Walk-in” ; 15% ;
“Call” ; 10% ;
6%  //all other situations
)

👁The current value should be a single value, “Web”, 15 … True 

⚠ so not >5200



SWITCH TRUE

• If you need ranges: SWITCH-TRUE

• CostRangeSwitch
= SWITCH ( TRUE() ;

Products[ProductCost]> 15000 ; "High" ; 
Products[ProductCost]> 8000 ; "Normal" ;
"Low"

)



Crearte a HighEnd column

• “Expensive cars” : Category =“CAR” && CatalogPrice > 20000

• “Expensive bikes” : Category =“BIKE” && CatalogPrice > 5000

• “Expensive Vans” : Category =“VAN” && CatalogPrice > 25000

=SWITCH( TRUE() ;

Products[ProductCategory]="CAR" && Products[CatalogPrice]>20000 ; TRUE() ;
Products[ProductCategory]="BIKE" && Products[CatalogPrice]>5000 ; TRUE() ;
Products[ProductCategory]="VAN" && Products[CatalogPrice]>25000 ; TRUE() ;
FALSE()
)



Use your relations

• Two tables are related via the one-many relation
RELATED-function

• A FACT table retrieving information from the DIM

• One value is returned

LOOKUPVALUE-function

• A relation does not need to exist

• One value is returned

RELATEDTABLE-function

• A DIM table retrieving information from the FACT

• Multiple lines are returned



RELATED

• In 3_B_01_CalculatedColumns

• Add the ProductName to the orders table: 
ProductName
=RELATED(  Product[ProductName]  )

• Calculate the margin per line: Line Margin

• Quantity * (product.cost- price)



LOOKUPVALUE : Big chief

• Create a column that will display the name of the CEO: Big Chief

• BIG chief 
= LOOKUPVALUE( Employees[Name] , 

Employees[Position] , "CEO" ) 



LOOKUPVALUE : Chief

• Create a column that will display the name of the "reportsto" : Chief

• Chief = LOOKUPVALUE( 
Employees[Name] , 
Employees[EmployeeID] , 
Employees[ReportsTo] )



LOOKUPVALUE : Department Chief

• Create a column that will display the name of the "manager" : of the 
corresponding department

• Manager = LOOKUPVALUE( 
Employees[Name],
Employees[Position] , "manager" ,
Employees[Department] , Employees[Department],
Employees[EndDate] , BLANK()

)



RELATEDTABLE

In 3_B_01_CalculatedColumns

• In the table Customers is a calculated column 
Orders
= COUNTROWS( Orders )
The results is not correct. Why?

• Create a new column that fixes the problem: Orders Rows 
= COUNTROWS ( 

RELATEDTABLE( Orders )
)



Exercise

1. Open 3_B_02_Columns

2. For every order calculate the absolute discount comparing the 
Catalogprice (in Products) and the PricePerUnit (in Orders)
• Column name: Discount abs 

• Set the Format as: Decimal Number (2 decimals)

3. For every product, count how many order lines exist
• Column name: Order Lines



Organize your model



Organize your Model

• Two related tables often share a column
• Customers.CustomerID vs Orders.CustomerID

• These columns are (only)necessary for the relation

Hide
View hidden 



Sort columns

• Column tools > Sort by column

Sort by column

Data



Where to create a measure

• Measures can be stored in any table of your data model

• In measures can easily be moved from on table to another

• Therefore, never include the table name (location) when referring to a 
measure



Measures table

Save all your measures in a separate table

Advantages

• All measures are in a single location

• When tables need to be reloaded (not refreshed) 
you don’t loose your measures



Create a measure "Table"

1. Home > Data > Enter data

2. Type a name for the measure table: "Analysis"

3. After the first measure is created, remove the empty Column1



Part 3 : Analysis



Basic aggregations



Create a measure

New measure



Basic aggregations

• Functions
• SUM, MAX, MIN …

• COUNT, COUNTA, DISTINCTCOUNT …

• COUNTROWS

• AVERAGE, STDEV.P, STDEV.S …

• These functions are similar to the functions in Excel

• Only one argument: TableName or ColumnName

• COUNTROWS( TableName )

• SUM( TableName[ColumnName] )



COUNT/SUM functions

• Open 4_A_01_Demo

• The number of Orders: Order Lines

=COUNTROWS( Orders )

• The number of Customers that Ordered: Actual Customers

=DISTINCTCOUNT( Orders[Customerkey] )

• Sum of Quantity ordered: Quantity Total

=SUM( Orders[Quantity] )



Create Visual

• Create a simple visual showing these measures

• Show the values vertically

• Break the values per Customercountry

• Insert a slicer for the ProductCategory



AVERAGE and STDEV

• In 4_A_01_Demo

• Calculate the average Quantity ordered: Quantity Avg

=AVERAGE( Orders[Quantity] )

• Calculate the Standard Deviation of the ordered Quantity: Quantity
StDev

=STDEV.P( Orders[Quantity] )

• Use the Measures in a visual together  with CustomerCountry



Getting started with variables



VAR-RETURN

=IF( ( [COST] - [PRICE] )> 2400 ;
( [COST] - [PRICE] ) * 0,06 ;
( [COST] - [PRICE] ) * 0,078
) 

=VAR Delta = ([COST] - [PRICE])

RETURN
IF(Delta >2400 ;

Delta * 0,06 ;
Delta * 0,078

)

Use variables to simplify complex measures

👁The VARiable is calculated only once

👁The VARiable only exists in this measure



Aggregating Expressions



Aggregating Expressions
• Functions

• SUMX, MAXX, MINX, AVERAGEX, STDEVX.P, STDEVX.S …

Arguments

• Expressions inside the function
• SUMX( Orders;

[Price]*[Quantity] )

• Temporary Tables
• AVERAGEX(

TOPN( 10;Customers;[revenue] );
[revenue] )



SUMX
• Open 4_B_01_Demo

• SUM of Expected Orders: Total Orders
=SUMX( Orders;

Orders[Quantity] * Orders[PricePerUnit] )

• Sales with Tax: Total TVA
=SUMX( Orders;

Orders[Quantity] * 
Orders[PricePerUnit]*Orders[BtwTvaVat] )

• Total Orders incl TVA
= [Total Orders] + [Total orders TVA]



SUMX - Challenge

• Calculate the total margin: Total Margin
Tip: SUM( Quantity*( Price-Cost ) )

=SUMX( Orders;  
[Quantity] 
* (

[PricePerUnit] - RELATED( Products[ProductCost] )
)

)

• Create a visual showing these values per country



Filters



FILTER()

• FILTER() is a table function; it returns a filtered table

• FILTER( Table ; Filter )

FILTER(Orders; Orders[Status]=“Cancelled”)

Generates a table containing all Cancelled Orders

⚠ So this can never be an answer of a measure



Cancelled Deals

• Sum of the Cancelled Deals : Total Cancelled Deals

=SUMX( 
FILTER(  Orders ; 

Orders[Status]=“Cancelled”
) ;

Orders[Quantity] * Orders[PricePerUnit] 
)



Closed Deals

• Sum of the Closed Orders: Total Sales

= SUMX( 
FILTER(  Orders ; 

Orders[Status]=“closed”
) ;

Orders[Quantity] * Orders[PricePerUnit] 
)

• Extra: Create a measure calculating the Success Rate
= [Total Sales] / [Total Orders]



Average to delivery

• Average Days to delivery =
AVERAGEX( Orders; 

Orders[Senddate]-Orders[Orderdate] )

• Average Days to delivery =
AVERAGEX( 

FILTER(  Orders ; 
Orders[Senddate]<> BLANK()

) ;
Orders[Senddate]-Orders[Orderdate] )

Strange Results



Filter Functions: ALL

• ALL cancels all filters in measure

• This allows us to create GrandTotals and those are important tot 
calculate Percentages

Arguments

• ALL( TableName )

• ALL( TableName[ColumnName] )

⚠ ALL creates a table with unique rows



All Orders
• Open 4_B_02_Demo

• Total Deals Net:=
SUMX( Orders ; 

Orders[Quantity] * Orders[PricePerUnit] )

• Total All Deals Net:=
SUMX( ALL( Orders ) ; 

Orders[Quantity] * Orders[PricePerUnit] )

• Total All Deals Net NOT:=
SUMX( ALL( Orders[PricePerUnit]; Orders[Quantity]) ; 

Orders[Quantity] * Orders[PricePerUnit] )



Bereken het percentage tov Grand Total

• the Total All Deals Net-measure is not always very relevant as such

• Divide Total Deals Net by Total All Deals Net

• Deals Net % :=
Total Deals Net / Total All Deals Net

• Nothing to do …
• Rewrite Deals Net % withour using the Total All Deals Net

Tip: use variables



ALLSELECTED

• ALLSELECTED Works similar to ALL

• But keeps the filters from outside the visual

Motor 4.767.847



CALCULATE



CALCULATE

• CALCULATE alters the applied filters.

• Structure: CALCULATE( expression ; Filter1 ; Filter2 …)
• Filter: column = static value

• =, <, >, <=, >= and <>

• Filter function: ALL, ALLEXCEPT, SAMEPERIODLASTYEAR…

Example
• Count Orders= 

CALCULATE( COUNTROWS( orders) ;
Orders[Status]=“Closed” )



Sales by Type

• Total Sales via Internet: Total Sales Internet

= CALCULATE( [Total Sales]
; Orders[SalesType] = “web“ )

• Total Sales via Internet: Total Sales Walk-in 

= CALCULATE( [Total Sales]
; Orders[SalesType] = “Visit“ )



Arguments

• = Equals

• && logical AND

• || logical OR

• Total Sales BeNeLux= 
CALCULATE( [Total Sales]; 

Customer[Country]=“BE”     ||
Customer[Country]=“LUX”   ||
Customer[Country]=“NL” )



Sales by Type

• Total Sales via Internet: Total Sales Call
Total Sales Calls=

CALCULATE( [Total Sales]
; Orders[SalesType] = “Call“
|| Orders[SalesType] = “Phone“)



Results per SalesType

• Share Walk-in to Total Sales: Share Walk-in

= DIVIDE( [Total Sales Walk-in ] ; 
[Total Sales] 

)



Filter Functions: ALL

• ALL cancels all filters applied to the measure

• This allows the creation of GrandTotals and these are important to 
calculate Shares

Arguments

• ALL( TableName )

• ALL( TableName[ColumnName] )



Shares per ProductType/Category

• Calculate the Total Sales of all Products

Total Sales All Products
= CALCULATE( [Total Sales];

ALL( Products )
)

• Calculate the Share of every product 
Share Per Product

=DIVIDE( [Total Sales];
[Total Sales All Products];
BLANK() 
)



Country Comparison 

• Create Total Sales all Countries
= CALCULATE( 

[Total Sales] ; 
All( Customers[CustomerCountry] )
)

• Create Share Per Country 
= DIVIDE( [Total Sales] ; [Total Sales all Countries] )



ALLEXCEPT()

• ALLEXCEPT will cancel all filters except the one specified

• Create Total Sales per Year
• = CALCULATE( 

[Total Sales] ; 
ALLEXCEPT( Dates; Dates[Year] )
)

• Create Share per Year
• = DIVIDE (  [Total Sales] ;

[Total Sales per Year]
)



Extra : ISFILTERED

• Use ISFILTERED to test if a filter is being used.

• You can remove Share over Categories if there is no filter on either
ProductType or ProductSize …

Share over Categories 2:=
IF( 

ISFILTERED( Products[ProductSize] ) ||   
ISFILTERED( Products[ProductType] ) ;

DIVIDE (  [Total Sales] ; [Total Sales per Category]  ) ;
BLANK()
)



USERELATIONSHIP()

• When multiple relations exist between 2 tables, 
only one is active.

• USERELATIONSHIP actives an inactive existing relationship



Total Invoiced

• Create a measure that calculates how much was invoiced in a given 
period.  Total Invoiced

• Total Invoiced 
= CALCULATE( [Total Sales];

USERELATIONSHIP( 
Dates[date] ; Orders[InvoiceDate]  )
)

• Compare the results in a table
Total Sales and Total Invoiced 
grouped by years and months



Limits of CALCULATE
• None, except...

• There are safeguards to ensure high performance
• Filters are not allowed to be too complex, like 

• Column = Measure

• Column = Formula

• Column = Column

• Measure = Measure

• =, <, >, <=, >= and <>

• So this doesn’t work
• Sales late delivered = 

CALCULATE( [Total Sales]
; Orders[SendDate]-Orders[Orderdate] > 5
)

For more complex situations use FILTER()



FILTER()

• FILTER( Table ; Filter )

• Sales late delivered := 
CALCULATE( [Total Sales]

; FILTER( Orders
; Orders[SendDate]-Orders[Orderdate] > 5 )

)



Summarize



Summarize

• Via Summarize you can compile tables that can then be analyzed. 

• Especially for calculating averages over certain periods

•

• For example, calculate a Monthly Average Sales
Monthly Average Sales:=

AVERAGEX( 
SUMMARIZE( Orders ; Dates[MonthKey] ; "Sales" ; [Total Sales] );
[Sales] )



Monthly Average Sales

• The average is the total of the 12 months divided 
by 12

1.010.302,04

12.123.624,53 / 12



CALCULATE



CALCULATE
• CALCULATE alters the applied filters.

• Structure: CALCULATE( expression ; Filter1 ; Filter2 …)
• Filter: column = static value

• =, <, >, <=, >= and <>

• Filter function: ALL, ALLEXCEPT, SAMEPERIODLASTYEAR…

Example
• Count Orders= 

CALCULATE( COUNTROWS( orders) ;
Orders[Status]=“Closed” )



Sales by Type

• Total Sales via Internet: Total Sales Internet

= CALCULATE( [Total Sales]
; Orders[SalesType] = “web“ )

• Total Sales via Internet: Total Sales Walk-in 

= CALCULATE( [Total Sales]
; Orders[SalesType] = “Visit“ )



Filter Functions: ALL

• ALL cancels all filters applied to the measure

• This allows the creation of GrandTotals and these are important to 
calculate Shares

Arguments

• ALL( TableName )

• ALL( TableName[ColumnName] )



Shares per ProductType/Category

• Calculate the Total Sales of all Products

Total Sales All Products
= CALCULATE( [Total Sales];

ALL( Products )
)

• Calculate the Share of every product 
Share Per Product

=DIVIDE( [Total Sales];
[Total Sales All Products];
BLANK() 
)



Country Comparison 

• Create Total Sales all Countries
= CALCULATE( 

[Total Sales] ; 
All( Customers[CustomerCountry] )
)

• Create Share Per Country 
= DIVIDE( [Total Sales] ; [Total Sales all Countries] )



ALLEXCEPT()

• ALLEXCEPT will cancel all filters except the one specified

• Create Total Sales per Year
= CALCULATE( 

[Total Sales] ; 
ALLEXCEPT( Dates; Dates[Year] )
)

• Create Share per Year
= DIVIDE (  [Total Sales] ;

[Total Sales per Year]

)



USERELATIONSHIP()

• When multiple relations exist between 2 tables, 
only one is active.

• USERELATIONSHIP actives an inactive existing relationship



Total Invoiced
• Create a measure that calculates how much was invoiced in a given 

period.  Total Invoiced

• Total Invoiced 
=

CALCULATE( [Total Sales];
USERELATIONSHIP( 
Dates[date] ; Orders[InvoiceDate]  )
)

• Compare the results in a table
Total Sales and Total Invoiced 
grouped by years and months



Limits of CALCULATE
• None, except...

• There are safeguards to ensure high performance
• Filters are not allowed to be too complex, like 

• Column = Measure

• Column = Formula

• Column = Column

• Measure = Measure

• =, <, >, <=, >= and <>

• This does NOT work
• Sales late delivered = 

CALCULATE( [Total Sales]
; Orders[SendDate]-Orders[Orderdate] > 5
)

For more complex situations use FILTER()



FILTER()

• FILTER() nulls the build-in safeguards

• FILTER() is a table function, it returns a filtered table

• FILTER( Table ; Filter )

• Sales late delivered 
= CALCULATE( [Total Sales]

; FILTER( Orders
; Orders[SendDate]-Orders[Orderdate] > 5 )

)



CALCULATE with/without FILTER
• Actual Orders =

CALCULATE(  [Deals Expected]

; Orders[Status] = “Closed“ )

• Actual Filtered Orders =
CALCULATE(  

[Deals Expected]
;FILTER (Orders 

; Orders[Status] = “Closed“ )
)

Adds/replaces a filter Filters the table



Time intelligence



Date Intelligence

• Date intelligence function
• TOTALYTD, TOTALQTD, TOTALMTD (running totals)

• SAMEPERIODLASTYEAR

• DATEADD

• …

• These functions need a Dimension to work; a Date Table

• The date table should be linked to your dates in the facts table



The Date Table



Date Table

• One keycolumn containing dates

• All dates in the reference period should exist
• e?.g. all days between 1/1/2010 and 31/12/2020

• Power Pivot: Design/ Mark as Date table

• Power BI: Modeling / Mark as Date table

• Additional information should be added like
• Year, weeknumber, IsWeekday, MonthName…



Where to get it from

• A date table can be 
• Imported like any other source

• Calculated in Power Query via M
• See hand-out

• Calculated in DAX (only Power BI)



Steps

1. Import the Date-table

2. Modeling / Mark as Date Table
1. Select the key column

3. Avoid summarization on columns

4. Sort the Month Name on using the Month (number)

Default Summarization

Sort by Column



Import a DateTable
• Open 4_D_01_DateIntel

• Create a Date table using the M code in 4_D_01_M_DataTable.txt

• Change the name of the table to: Dates

• Mark the table as Date Table

• After loading the data
• Change the sort order of the columns

• Month, Month Year and Month (Abbr)

• Switch off the default summarization for:
• Year and Month

• Hide the Monthkey column

• Create relations

• Use Year, Quarter and Month Name in the visual



ISO Weeknumbers

• Copy the contents from M_function_ISOWeeknum.txt

• Create a blank query to create a custom function
• Name: fx_ISOweeknumber

• Paste the contents in the advanced editor

• Go to the Dates-query

• Add Column / Invoke custom function
• Name: Weeknumber

• Select the Dates[Date] column



Year To Date



Naming conventions
Acronym Description

YTD Year-to-date

QTD Quarter-to-date

MTD Month-to-date

WTD Week-to-date

R12M Rolling 12 Months

PY Previous year

PQ Previous quarter

PM Previous month

YOY Year-over-year

PYC Previous year complete

PQC Previous quarter complete

PMC Previous month complete



TOTALYTD()

• Creates a running total (per calendar year)

• Arguments
• TOTALYTD( Expression ; Dates[Date] )

• Example

• OrderCountYTD=
TOTALYTD( COUNTROWS( Orders );

Dates[Date] )

Dates[Date] = keycolumn



Total Sales YTD

• Open 4_D_02_DateCalculations

• Create a running total on the existing measure Total Sales : 
Total Sales YTD

=TOTALYTD( [Total Sales] ; Dates[Date] )

• Add Total Sales YTD to 
the visual/PivotTable



DATESYTD()

• Creates a table containing all dates up to the last date in the 
context of the selected year

• Arguments
• DATESYTD( Dates[Date] )

• So Total Sales YTD could also be written as:
= CALCULATE (

[Total Sales] ;
DATESYTD( Dates[Date] )
)

Dates[Date] = keycolumn



DATESBETWEEN()
• Creates a table containing all dates between the two given dates

• Arguments
• DATESBETWEEN( Dates[Date] ; Startdate ; Enddate )

• So Total Sales YTD could therefore be written as:
= CALCULATE (

[Total Sales] ;
DATESBETWEEN( Dates[Date];

DATE ( YEAR ( MAX ( Dates[Date] ) ) ; 1; 1 ) ;
MAX( Dates[Date] )
)

)



DATESBETWEEN() - Total To Date

• DATESBETWEEN doesn't seem to be very useful …

• But what if you don't want to restart at the beginning of the year

• Total Sales to Date could therefore be written as:
= CALCULATE (

[Total Sales] ;
DATESBETWEEN( Dates[Date];

DATE( 1900 ; 1; 1) ;
MAX( Dates[Date] )
)

)



Total to Date - Presentation problem

• When using a TD there are answers even if there are no new sales

• Check for every date if it is before the last "orderdate"

• Calculated column:
DateWithSales = Dates[Date] <= MAX ( Orders[Orderdate] )

• Use the value to filter the visual



DatesInPeriod - Rolling 12 Months 

• DATESINPERIOD returns all dates in a given period

• Total Sales R12M :=
CALCULATE(

[Total Sales] ;
DATESINPERIOD( 

Dates[Date];
MAX( Dates[Date] ); 
-12;
MONTH )

)

YEAR
QUARTER
MONTH

DAY

In
te

rv
a
ls



Total Quantity to Date

Total Quantity 
= SUMX(FILTER( Orders; Orders[Status]= "closed"); Orders[Quantity] )

Total Quantity To Date 
= CALCULATE(

[Total Quantity ];
DATESBETWEEN( Dates[Date];

DATE( 1900 ; 1; 1) ;
MAX( Dates[Date] )
)

)



Total Delivered to Date

Quantity Delivered
= SUM( Deliveries[Quantity] )

Total Delivered To Date 
= CALCULATE(

[Quantity Delivered ];
DATESBETWEEN( Dates[Date];

DATE( 1900 ; 1; 1) ;
MAX( Dates[Date] )
)

)



Total Stock

• Create a measure to get the total start value for the stock
• Qty Stock Start = SUM( Products[ProductStockStart] )

• Create a measure to calculate the current level of the stock
• Total Stock = [Qty Stock Start]  +  [Total Delivered To Date ]

- [Total Quantity To Date] 

• Create a table using displaying these values per month

• Add a slicer for the year



Total Stock



Date comparisons



SAMEPERIODLASTYEAR

• Calculate the measure over the same period of the previous year

• Requested period
• Total Sales = CALCULATE(  [Deals Expected] ; Orders[Status] = “Closed“ )

• Period previous year: Actual Orders PY
• Total Sales PY= 

CALCULATE(
[Total Sales] ;
SAMEPERIODLASTYEAR(  Dates[date]   )
)



Turnover Previous Year

• Calculate the Total Sales of the previous year: 
Total Sales PY

=CALCULATE( [Total Sales];
SAMEPERIODLASTYEAR( Dates[Dates] ) )

• Create a Table/Matrix visual

• Calculate the growth Year over Year : Total Sales YoY
=DIVIDE(  [Total Sales] - [Total Sales PY] ;

[Total Sales PY] ;
BLANK()
)



DATEADD()

• DATEADD(Dates; nbr Intervals; Interval)

• Calculate the Total Sales of 2 years ago using DATEADD: 
Total Sales -2Y

=CALCULATE( [Total Sales]
; DATEADD( Dates[Date]

; -2 
; Year ) 

)

YEAR
QUARTER
MONTH

DAY

In
te

rv
a
ls



Total Sales Previous Quarter

• Calculate the Total Sales of the selected period 1 quarter ago : 

Total Sales PQ
=CALCULATE( [Total Sales]

; DATEADD( Dates[Date] ) 
; -1
; Quarter 

)

Total Sales QoQ

=DIVIDE(  [Total Sales] - [Total Sales PQ] ;
[Total Sales PQ] ;
BLANK()
)



PARALLELPERIOD()

• PARALLELPERIOD(Dates; nbr Intervals; interval )
• Returns the total of complete given interval

TotalSales-1Y parallel = 
CALCULATE( [Total Sales]; 

PARALLELPERIOD( Dates[Date] 
;-1; YEAR ) 
)



Compare to previous month

• Imagine a situation where you want to compare 
the selected month (month to date) with the 
total of last month



Compare to previous month

• Total Sales PMC
= CALCULATE( [Total Sales] ;

PARALLELPERIOD( Dates[Date]; -1 ; MONTH )
)

• Perc Last Month
= DIVIDE( 

TOTALMTD([Total Sales]; Dates[Date]) ;
[Total Sales PMC] )



Visualisations in Power BI



Visualisaties in Power BI

• Report design and Page-settings

• Add, Edit and Delete visuals

• Format visuals

• Slicers, Filters and interactions

• Tooltips

• Buttons and bookmarks



Report design and Page-settings

• Apply a background image or color

• Click on the page and choose

Alignment of visuals

• Use gridlines
• View / Show Gridlines

Or

• Apply a background image
with the necessary canvas

Next slide

Transparency



Create a Background canvas

• Open PowerPoint and draw a canvas

• Choose File / Export and save as PNG 

next slide



Apply a Background canvas

• Click on the page and choose

• In the section Page background, click Add image

• Change the Transparency

Tip

Canvas and background are applied to the current page

• Right click to create a duplicate

• Create a "hidden template"



Themes

• Standard themes

• Browse for themes voor Company branded
themes

• Customize & save current Theme



Apply a background and theme

• Open 5_A_01_Page_Report.pbix

• Set Forest.png as wallpaper

• Apply the Training.json theme

• Reorganise the visuals

• Change the transparency of the
• Wallpaper

• Visuals



Add visuals



Adding a visual

Visual – Data – Format – Filter 
1. Click anywhere on your Page

2. Select the desired visual

3. Find and add the Fields and Measures

4. Change the formatting

5. Adjust filters toe



Tip

• Don't add summaries of fact data

• Create and use measures !!!

Tip: 

Right click on the fact data and choose Hide

* Deliveries Quantity

* Orders Quantity

Correct

Wrong



Default behaviour: Data - Visual

• Measure → Columnchart

• Tekst → Table

• Geographical data → Map

Change the visualtype

1. Select the visual

2. Click on a different type



Formatting of the Visuals
• Use a theme for the default settings

• Click 

Charts 

• Each element can be given a different color

Tables

• Default formatting in the Style section

• Striped rows and columns

• Conditional Format

Visual
General

Search



Context



Context

• Applying context to values gives a deeper meaning to the number 
you are looking at

• This year's value compared to last year’s

• This category compared to all categories

• An Average with the Standard Deviation and the size of the population



Another measure

Comparing with last year’s values using a measure

Total Sales -1Y



Data labels

Apply data labels for easy interpretation

Labels



Normal tooltips

Add additional information in the tooltip

Tooltips



Tooltip Page

Create a tooltip page

1. Create a separate page

2. Change the page settings
1. Page Information: Tooltip – On

2. Page size: Tooltip

3. Add visuals

Use a tooltip page

1. Select a visual

2. Settings Tooltip, select the 
page



Tooltip Exercise

• In the file 5_B_01_Visuals.pbix page Exercise
Average delivery in days for late deliveries (Delivery > 3 days)

1. Add labels to the visual

2. Calculate the StDev for late deliveries and add this to the tooltip
StDev late delivery  

= STDEVX.P(  FILTER( Orders ; 
Orders[SendDate] - Orders[Orderdate] > 3 ) ;
Orders[SendDate] - Orders[Orderdate]

)



Tooltips exercise

Count the number of late deliveries and add this to the tooltip 
Number of late deliveries  

= COUNTROWS( FILTER(Orders ; 
Orders[SendDate] - Orders[Orderdate] > 3 )

)



Slicers

1. Go to 5_B_02_Interactions.pbix page  Slicers exercise

2. Add a SalesType slicer
1. Allow multiple selections via CTRL

2. Change the list to buttons

3. Change the colour of the buttons

3. Add a slicer on the year
1. Change the list to buttons

2. Make it only interact with the PIE chart



Interaction

• Visuals interact with each other

• The interaction can be stopped/changed 

1. Select the source visual 
• The visual that should/shouldn’t control other visuals

2. Click Visual Tools – Format and click Edit interactions

3. Use the buttons on the other visuals to change the interaction

Filter

Highlight

No interaction



Change the interactions

Open the file 5_B_02_Interactions.pbix

1. Change the interactions between the Year slicer and the charts

2. Remove the interaction between the different Total … by Year
charts



Slicers

• Slicers are a very visual way to filter the data

• One slicer, mutliple modes

List

Dropdown

List - vertical

General/ Orientation/ Horizontal

List - horizontal



Date and number slicers

Date Slicer

Number Slicer



Getting coffee



References & Guides



Power Pivot 
and Power BI

• Rob Collie & Avichal Singh

• English

• Focus
• From basics to advanced

• All Power Pivot versions 
supported



Collect, Combine and 
Transform Data using 
Power Query in …

• Gil Raviv

• English

• Focus on
• Power Query

• Missing



The Definitive Guide 
to DAX

• Alberto Ferrari & Marco Russo

• English

• Focus on
• PowerPivot DAX

• Missing
• Power BI

• Power Query



Websites

• https://docs.microsoft.com/en-us/power-bi/
• Official Documentation

• https://powerbi.microsoft.com/en-us/blog/
• Official Blog (What’s new)

• http://www.powerpivotpro.com/
• Rob Collie

• https://www.sqlbi.com/
• Marco Russo and Alberto Ferrari

• https://www.kasperonbi.com/
• Kasper de Jonge

http://www.powerpivotpro.com/
https://powerbi.microsoft.com/en-us/blog/
http://www.powerpivotpro.com/
https://www.sqlbi.com/
https://www.kasperonbi.com/


DANK U

MERCI

THANK YOU

GRACIAS

DANKE

Peter De Laet

Trainer & 

Training Manager

Peter.Delaet@learnia.be
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